好咧
就这样吧

关于sf.net上的网站必须刷新才显示最新内容的解决办法

这两天测试了一下SourceForge.NET提供的免费空间。感觉除了偶尔会连接不上以外,访问速度还是蛮可观地,赞一下先!但是,在使用的过程中,发现新发布的内容必须要在浏览器中强制刷新一下才会显示出来,感觉有些郁闷。经过一番摸索,终于搞定。下面就介绍一下我的解决方法:

首先,让程序输出时不使用浏览器缓存:

[php]

header( "Expires: Mon, 26 Jul 1997 05:00:00 GMT" );
header( "Last-Modified: " . gmdate("D, d M Y H:i:s") . " GMT" );
header( "Cache-Control: no-store, no-cache, must-revalidate" );
header( "Cache-Control: post-check=0, pre-check=0", false );
header( "Pragma: no-cache" );

[/php]

然后,在.htaccess文件中加上如下部分:

[html]<ifmodule mod_expires.c> <FilesMatch ".(html|htm)$"> Header set Cache-Control "max-age=43200″ </FilesMatch> #cache css, javascript and text files for one week <FilesMatch ".(js|css|txt)$"> Header set Cache-Control "max-age=604800″ </FilesMatch> #cache flash and images for one month <FilesMatch ".(flv|swf|ico|gif|jpg|jpeg|png)$"> Header set Cache-Control "max-age=2592000″ </FilesMatch> #disable cache for script files <FilesMatch ".(pl|php|cgi|spl|scgi|fcgi)$"> Header unset Cache-Control </FilesMatch> </ifmodule> <ifmodule mod_deflate.c> AddOutputFilterByType DEFLATE text/html text/plain text/xml application/x-httpd-php #AddOutputFilter DEFLATE js css </ifmodule>[/html]
 

相关推荐

最新回复